iebroken

SharePoint Issues when you use Internet Explorer 11

[Updated: 2014-02-05]

IE11 or Internet Explorer version 11, have some serious issues when you use it to work with SharePoint. It feels like, Microsoft, missed a step in the testing process when they launched that browser. Most things that IE11 breaks can be fixed by adding *.domain to the compatibility view. I guess that I am not the only one who is getting frustrated with IE11. I don’t think that adding a domain to compatibility View is the right solution for a company to use IE11 for SharePoint. But unfortunately this is, to the best of my knowledge, the only solution, next to not upgrading you have. I really recommend, not upgrading, if you have SharePoint as your Company Intranet platform.

So I decided to make a list of things that adding the domain to the Compatibility View will fix.

List of SharePoint Issues when using IE11 without Compatibility View:

  1. Issues with editing webparts and gaining access to webpartzones
  2. Issues with SharePoint not saving your changes in Content zones on save
  3. Issues with changing or navigation to pages in InfoPath Forms

List of SharePoint Issues when using IE11 with Compatibility View:

  1. Unable to open InfoPath Forms in browser view

If you have other issues that adding the domain to Compatibility View will fix, please leave a comment and I will update the post.

15 replies
  1. stark
    stark says:

    As of the last two or three days everyone in my company is having serious rendering issues and javascript errors when using IE11 but everything works fine in Chrome. Very frustrating, compatibility settings does not fix it either.

    Reply
  2. Barbara
    Barbara says:

    Check that they are using IE 32bit NOT 64bit. That solved it for us. 32bit is run from c:\Program Files (x86)\Internet Explorer\iexplore.exe.

    I hope that helps.

    Reply
  3. Sunil Kumar
    Sunil Kumar says:

    Hi, I am facing issue with selecting image in a publishing page. When i click on add image from sharepoint. This opens AssetImagePicker dialog and click on browser and selected the image from SharePoint.
    But after clicking ok, the link for the image is not passed on to the browse field.
    This is working fine on IE8 and chrome.
    Can you please help?

    Thanks.
    -Sunil

    Reply
  4. Neomi
    Neomi says:

    After upgrading to IE11; I doesn’t open 32-Bit IE from c:\Program Files (x86)\Internet Explorer\iexplore.exe In fact it also opens 64-bit IE. Can someone help if this resolved? Also I can’t see Datasheet view of List.

    Reply
  5. sowmya
    sowmya says:

    When ever a item is created in sharepoint , workflow gets cancelled in IE , but it works fine in chrome. can one of you suggest on this please…

    Reply
  6. Jason Linville
    Jason Linville says:

    Unable to open doc libraries in explorer mode. I’ve added the domain to compatibility settings, using IE11 32bit, windows 8.1 64bit, sharepoint foundation 2010. The error I receive is “Your client does not support opening this list with Windows Explorer.” I’m attempting to open a Site Assets Library. Any suggestions?

    Reply
    • Ulrich Gerting Bojko
      Ulrich Gerting Bojko says:

      Hi Jason

      Is your IE11 not in 64 bit? I would go with that. Also try looking at your Alternate Access mappings in SharePoint. Make sure that the URL from which you try this, is in the default zone. There are many things that could be an issue, and it can be anything from DNS, AD, Group Policies or SharePoint.

      Do you get any errors in the log?

      All the best, Ulrich

      Reply
  7. HOB
    HOB says:

    My issue was within the firewall, using intranet sites built on SharePoint. The “use compatibility view for all intranet site” was checked. I unchecked it and all is well.

    Reply
  8. Stephen Russell
    Stephen Russell says:

    Win7, IE11, SP2013, SQL12, and SSRS the Printer Icon never renders for users to print a report?

    Have updated the ReportViewer dll, SP1 for SP2013, SP1 for SqlServer with cum patch 8 applied. Reset Sql test server and still no Printer Icon.

    Reply

Leave a Reply

Want to join the discussion?
Feel free to contribute!

Leave a Reply